PostePay Outage

Incident Report for Tink providers Italy

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 04:14 UTC

Investigating

Investigating - Tink automatic monitoring service has detected a service outage. Affected flow(s): auto refresh.
Posted Mar 19, 2025 - 03:05 UTC
This incident affected: PostePay.