Chebanca - Major outage
Incident Report for Tink providers Italy
Resolved
This incident is resolved since 2024-07-13 (~23:00 CEST)
Posted Jul 14, 2024 - 10:23 UTC
Identified
We have identified that Chebanca is under a maintenance from 2024-07-13 (~00:05 CEST). We don't have a timeline for this maintenance at the moment. All bank services are currently unavailable.
We will update when a significant change to the situation occurs.
Posted Jul 13, 2024 - 09:35 UTC
This incident affected: Mediobanca Premier (CheBanca).