Banca Monte dei Paschi di Siena Open Banking - Account Information Services Degraded performance

Incident Report for Tink providers Italy

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Nov 11, 2025 - 10:27 CET

Identified

We are currently investigating an issue with Banca Monte dei Paschi di Siena.
- Affected users: 90%
- Affected flow: manual login, it affects mostly login.
- Start Time: 08.11.2025 06:00 CET
- Bank side error: Timeouts
- Provider name: it-mps-oauth2
Posted Nov 08, 2025 - 10:50 CET
This incident affected: Banca Monte dei Paschi di Siena.