Mediobanca - Major outage

Incident Report for Tink providers Italy

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jul 12, 2026 - 18:25 CEST

Investigating

We are currently investigating an issue with Mediobanca.
Posted Jul 12, 2026 - 09:21 CEST
This incident affected: Mediobanca Premier (CheBanca).