Findomestic Banca - Major Outage with Payments
Incident Report for Tink providers Italy
Update
We are continuing to work on a fix for this issue.
Posted Oct 09, 2023 - 08:44 UTC
Identified
We have identified the issue and are in contact with Findomestic Banca for further information.
We will update when a significant change to the situation occurs.
Posted Oct 06, 2023 - 17:47 UTC
This incident affects: Findomestic Banca.