Fineco Open Banking - Degraded Performance
Incident Report for Tink providers Italy
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Jul 17, 2024 - 11:35 UTC
Investigating
We are currently investigating an issue with Fineco Open Banking.
Posted Jul 04, 2024 - 20:38 UTC
This incident affected: Fineco.