Banca Widiba Open Banking - Major Outage
Incident Report for Tink providers Italy
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Mar 02, 2024 - 07:27 UTC
Investigating
We are currently investigating an issue with Banca Widiba Open Banking.
Posted Mar 01, 2024 - 16:23 UTC
This incident affected: Banca Widiba.