Banca Monte dei Paschi di Siena Open Banking & Banca Widiba Open Banking - Degraded performance
Incident Report for Tink providers Italy
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Mar 04, 2024 - 10:22 UTC
Identified
We have identified the issue and are in contact with the banks for further information.

We will update when a significant change to the situation occurs.
Posted Feb 16, 2024 - 09:57 UTC
This incident affected: Banca Monte dei Paschi di Siena and Banca Widiba.