BPER Banca - Partial Outage

Incident Report for Tink providers Italy

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Oct 07, 2025 - 12:04 CEST

Investigating

We are currently investigating an issue with BPER Banca.
Posted Oct 04, 2025 - 11:43 CEST
This incident affected: BPER Banca.