Banco BPM - Degraded performance

Incident Report for Tink providers Italy

Update

We're meanwhile experiencing a major outage for the provider. The investigation is still ongoing.
Posted Jun 30, 2025 - 08:11 UTC

Investigating

We are currently investigating an issue with Banco BPM.
Posted Jun 25, 2025 - 07:37 UTC
This incident affects: Banco BPM.